React components and demo for the Tabler UI theme.

Overview

Update - June 2019: Version 2

Alpha now available on NPM:

npm install [email protected] yarn add [email protected]

Check out the latest progress and get involved on this branch, or add your thoughts and requests to this issue.

Tabler React

React implementation of the Tabler Dashboard UI Kit

NPM Type definitions Greenkeeper badge Commitizen friendly

Demo | Documentation | Issues | Slack.

Install

Make sure you have Node.js 8+ and yarn installed.

yarn add tabler-react

Example

import React, { Component } from "react";

import "tabler-react/dist/Tabler.css";

import { Card, Button } from "tabler-react";

class MyCard extends Component {
  render() {
    return (
      <Card>
        <Card.Header>
          <Card.Title>Card Title</Card.Title>
        </Card.Header>
        <Card.Body>
          <Button color="primary">A Button</Button>
        </Card.Body>
      </Card>
    );
  }
}

For more examples and documentation see the demo website

Contributing

There are plenty of opportunities to get involved. Pick an outstanding task, let us know what you are working on and fire away with any questions.

The package is made up of 2 main folders:

  • /src contains all the Tabler React components
  • /example is our create-react-app based demo website

To setup and run a local copy:

  1. Clone this repo with git clone https://github.com/tabler/tabler-react
  2. Run yarn install in the root folder
  3. Run yarn install in the example folder
  4. In seperate terminal windows, run yarn start in the root and example folders.

You should now be up and running with live browser reloading of the example website while you work on Tabler React components in the /src folder.

When you're done working on your changes, submit a PR with the details and include a screenshot if you've changed anything visually.

License

MIT © jonthomp, AaronCoplan and the contributors.

Issues
  • Update rollup to the latest version 🚀

    Update rollup to the latest version 🚀

    The devDependency rollup was updated from 0.68.0 to 1.2.0.

    This version is not covered by your current version range.

    If you don’t accept this pull request, your project will work just like it did before. However, you might be missing out on a bunch of new features, fixes and/or performance improvements from the dependency update.


    Release Notes for v1.2.0

    2019-02-17

    Features

    • Fewer renamed variables due to a completely reimplemented deconflicting logic (#2689)

    Bug Fixes

    • Respect rendered and tree-shaken exports when determining chunk hashes (#2695)
    • Fix an error when dynamic imports end up in the same chunk as one of their importees (#2677)
    • Do not generate invalid code when expressions containing IIFEs are simplified (#2696)
    • Do not throw an error when more than ten bundles are watched (#2700)
    • Treat re-exported globals in a spec-compliant way (#2691)
    • Fix issues related to wrongly renamed variables (#2689)
    • Do not throw an error if config files contain non-default exports (#2673)
    • Improve type of RollupOutput.output to guarantee at least one chunk (#2679)

    Pull Requests

    Commits

    The new version differs by 61 commits.

    • 60e8df2 1.2.0
    • 56ff3e3 Update changelog
    • 19a7727 Reimplement variable deconflicting logic (#2689)
    • fe84e00 Update changelog
    • db42a04 Prevent final resolution and facade creation for inlined dynamic imports (#2677)
    • 4d082b0 Respect rendered exports when generating chunk hashes (#2695)
    • 14a17af Correctly render function expression inside simplified expression statements. (#2696)
    • 0a46310 Add a fix for MaxListenersExceededWarning (#2700)
    • 1454b90 Update rollup-pluginutils (#2703)
    • d883243 Update changelog
    • f8faa4b Allow config files to contain non-default exports (#2673)
    • d6a865e Update changelog
    • 1ae20fc Improve type of RollupOutput.output (#2679)
    • 7f79ab1 Update changelog
    • c702f3a Fix typo in export-globals test (#2693)

    There are 61 commits in total.

    See the full diff

    FAQ and help

    There is a collection of frequently asked questions. If those don’t help, you can always ask the humans behind Greenkeeper.


    Your Greenkeeper bot :palm_tree:

    greenkeeper released 
    opened by greenkeeper[bot] 38
  • Update webpack to the latest version 🚀

    Update webpack to the latest version 🚀

    Version 4.9.0 of webpack was just published.

    Dependency webpack
    Current Version 3.12.0
    Type dependency

    The version 4.9.0 is not covered by your current version range.

    If you don’t accept this pull request, your project will work just like it did before. However, you might be missing out on a bunch of new features, fixes and/or performance improvements from the dependency update.

    It might be worth looking into these changes and trying to get this project onto the latest version of webpack.

    If you have a solid test suite and good coverage, a passing build is a strong indicator that you can take advantage of these changes directly by merging the proposed change into your project. If the build fails or you don’t have such unconditional trust in your tests, this branch is a great starting point for you to work on the update.


    Release Notes v4.9.0

    Features

    • BannerPlugin supports a function as banner option
    • allow serve property in configuration schema
    • add entryOnly option to DllPlugin to only expose modules in the entry point
    • Allow to choose between webpack-cli and webpack-command
    • improve error message when JSON parsing fails
    • allow BOM in JSON
    • sort usedIds in records for stablility

    Bugfixes

    • align module not found error message with node.js
    • fix behavior of splitChunks when request limit has reached (caused suboptimal splitting)
    • fix handling of RegExp in records (caused absolute path in records)
    • fix handling of circular chunks (caused missing __webpack_require__.e)
    • runtimeChunk is even generated when all modules are moved by splitChunks (caused multiple runtime chunks instead of single one)
    • string ids are no longer recorded (caused duplicate chunk ids)
    • fix link to migration guide in error message

    Internal changes

    • add more typings
    • Use travis stages
    • add many-pages example
    Commits

    The new version differs by 1757 commits ahead by 1757, behind by 8.

    • bb0731d 4.9.0
    • be6bdff Merge pull request #7385 from moondef/moondef-patch-1
    • b77addd Merge pull request #7187 from byzyk/enhancement/prettierignore
    • 2f3e7d4 Merge pull request #7331 from dev-drprasad/add-jsdoc-annotations-cached-merge
    • 70c608c Merge pull request #7387 from webpack/bugfix/record-string-ids
    • 69567a1 update test case to reflect change
    • 8af0320 Merge pull request #7344 from asapach/master
    • 713292f update bot for jest tests
    • 79aa13d Merge pull request #7386 from webpack/bugfix/runtime-chunk
    • 67717ab Merge pull request #7383 from webpack/ci/improvements
    • 72a45ab speed up CI
    • f026310 only record number ids
    • 25c7b07 Fix link
    • 374376d fixes #7382
    • aa99385 added a note about production mode

    There are 250 commits in total.

    See the full diff

    FAQ and help

    There is a collection of frequently asked questions. If those don’t help, you can always ask the humans behind Greenkeeper.


    Your Greenkeeper bot :palm_tree:

    greenkeeper blocked do not merge 
    opened by greenkeeper[bot] 32
  • yarn install throwing errors: error Command failed with exit code 1.

    yarn install throwing errors: error Command failed with exit code 1.

    Hello devs, I saw you're making better UX ready admin. I just loved it & to explore it in deapth, I cloned and installed Yarn Dependencies as suggested in readme. Which have gone something unexpected. My bash history as follows: (Kindly help me, if I'm missing something)

    For root folder:

    Windows PowerShell
    Copyright (C) Microsoft Corporation. All rights reserved.
    
    PS D:\Playground\tabler> git clone https://github.com/tabler/tabler-react
    Cloning into 'tabler-react'...
    remote: Enumerating objects: 262, done.
    remote: Counting objects: 100% (262/262), done.
    remote: Compressing objects: 100% (262/262), done.
    remote: Total 8668 (delta 199), reused 17 (delta 0), pack-reused 8406
    Receiving objects: 100% (8668/8668), 42.06 MiB | 447.00 KiB/s, done.
    Resolving deltas: 100% (5676/5676), done.
    Checking out files: 100% (1401/1401), done.
    
    PS D:\Playground\tabler> cd .\tabler-react\
    
    PS D:\Playground\tabler\tabler-react> yarn install
    yarn install v1.12.1
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    info There appears to be trouble with your network connection. Retrying...
    info There appears to be trouble with your network connection. Retrying...
    info [email protected]: The platform "win32" is incompatible with this module.
    info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation.
    [3/4] Linking dependencies...
    warning " > [email protected]" has incorrect peer dependency "[email protected]^7.2.3".
    warning " > [email protected]" has incorrect peer dependency "[email protected]^4.1.1".
    warning " > [email protected]" has incorrect peer dependency "[email protected]^5.1.1".
    warning "react-styleguidist > [email protected]" has incorrect peer dependency "[email protected] || 0.13.0".
    warning "react-styleguidist > [email protected]" has incorrect peer dependency "[email protected]^2.2.0 || ^3.0.0".
    warning "react-styleguidist > webpack-dev-server > [email protected]" has incorrect peer dependency "[email protected]^1.0.0 || ^2.0.0 || ^3.0.0".
    [4/4] Building fresh packages...
    $ yarn run build && yarn run copytablercsstodist
    yarn run v1.12.1
    $ yarn run copytablercsstodist && rollup -c && yarn run flow:copy-source
    $ mkdir -p dist && cp src/Tabler.css src/Tabler.RTL.css dist/ && cp -r src/fonts src/images dist/
    'cp' is not recognized as an internal or external command,
    operable program or batch file.
    error Command failed with exit code 1.
    info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
    error Command failed with exit code 1.
    info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
    error Command failed with exit code 1.
    info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
    
    PS D:\Playground\tabler\tabler-react> yarn start
    yarn run v1.12.1
    $ yarn run copytablercsstodist && rollup -c -w
    $ mkdir -p dist && cp src/Tabler.css src/Tabler.RTL.css dist/ && cp -r src/fonts src/images dist/
    A subdirectory or file -p already exists.
    Error occurred while processing: -p.
    A subdirectory or file dist already exists.
    Error occurred while processing: dist.
    error Command failed with exit code 1.
    info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
    error Command failed with exit code 1.
    info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
    PS D:\Playground\tabler\tabler-react>
    
    

    and for example folder in separate terminal from VS Code.

    
    Windows PowerShell
    Copyright (C) Microsoft Corporation. All rights reserved.
    
    PS D:\Playground\tabler> cd .\tabler-react\example\
    PS D:\Playground\tabler\tabler-react\example> yarn install
    yarn install v1.12.1
    [1/4] Resolving packages...
    [2/4] Fetching packages...
    info [email protected]: The platform "win32" is incompatible with this module.
    info "[email protected]" is an optional dependency and failed compatibility check. Excluding it from installation.
    [3/4] Linking dependencies...
    warning " > [email protected]" has unmet peer dependency "@types/[email protected]^3.0.0".
    warning " > [email protected]" has unmet peer dependency "@types/[email protected]^2.1.29".
    warning " > [email protected]" has unmet peer dependency "@types/[email protected]^15.0.0 || ^16.0.0".
    [4/4] Building fresh packages...
    
    Done in 274.03s.
    PS D:\Playground\tabler\tabler-react\example> yarn start
    yarn run v1.12.1
    $ react-scripts start
    Starting the development server...
    Failed to compile.
    
    ./src/HomePage.react.js
    Module not found: Can't resolve 'tabler-react' in 'D:\Playground\tabler\tabler-react\example\src'
    Compiling...
    
    
    opened by asharamseervi 24
  • Build all demo pages

    Build all demo pages

    • [x] Home/Dashboard

    Interface

    • [x] Cards Design
    • [x] Charts
    • [x] Pricing Cards

    Components

    • [ ] Maps
    • [ ] Icons
    • [x] Store
    • [ ] Blog
    • [ ] Carousel

    Pages

    • [ ] Profile @MrJarv1s
    • [x] Register
    • [x] Login
    • [x] Forgot Password
    • [x] 400 error
    • [x] 401 error
    • [x] 403 error
    • [x] 404 error
    • [x] 500 error
    • [x] 503 error
    • [x] Email
    • [x] Empty Page
    • [ ] RTL mode

    • [x] Form Elements

    • [x] Gallery
    help wanted good first issue 
    opened by jonthomp 24
  • Tooltip

    Tooltip

    This PR resolves #114

    The new tooltip use the original Tabler.css classes in addition to a new stylesheet included with the component.

    fulltooltip

    Before merging, these need to be completed:

    • [x] Add placement-based arrow positioning
    opened by Greg-Hamel 22
  • Add Typescript typings

    Add Typescript typings

    When this project is in a better state it would be great to have Typescript typings (componentName.d.ts files) included in the package so that it can easily be used together with Typescript.

    enhancement help wanted 
    opened by panmau 17
  • Build all base components

    Build all base components

    We need help getting all the base components built, anything without a user next to it is available so just let us know what your working on and we'll keep the list updated:

    • [x] Avatar
    • [x] Badge
    • [x] Button
    • [x] Basic Card
    • [x] Card Footer
    • [x] Pricing Card
    • [x] Store Card
    • [x] Gallery Card
    • [x] Container
    • [x] Dropdown
    • [x] Dimmer
    • [x] Form
    • [x] Form select button groups
    • [x] Form field set
    • [x] Form toggle switches
    • [x] Form radios
    • [x] Form checkboxes
    • [x] Form custom file input
    • [x] Form input group text and button appends
    • [x] Form input group prepend
    • [x] Form select
    • [x] Grid
    • [x] Header
    • [x] Icon
    • [x] Nav
    • [x] Page
    • [x] Page/Website header
    • [x] Page/Website navbar
    • [x] Page/Website footer
    • [x] Table
    • [x] Text
    • [x] Alert
    • [x] Progress
    • [x] Stamp
    help wanted good first issue 
    opened by jonthomp 12
  • Add Tooltip Component

    Add Tooltip Component

    Tabler uses tooltips for a number of items. For example, the media component uses tooltips: screen shot 2018-04-28 at 17 10 27

    Since we are trying to get rid of bootstrap components, a component could be developed from using react-popper.

    assigned 
    opened by Greg-Hamel 12
  • Update react-styleguidist to the latest version 🚀

    Update react-styleguidist to the latest version 🚀

    The devDependency react-styleguidist was updated from 8.0.6 to 9.0.0.

    This version is not covered by your current version range.

    If you don’t accept this pull request, your project will work just like it did before. However, you might be missing out on a bunch of new features, fixes and/or performance improvements from the dependency update.


    Release Notes for v9.0.0

    👋 Support Styleguidist on Open Collective 👋

    New features and breaking changes

    Do not put components into global namespace

    Finally we’ve fixed one of the oldest and weirdest issues. Style guide components are no longer accessible on window. Only the current component is accessible in the example context (not on window). You need to explicitly import any other component.

    Current component (like Button in this example) is always accessible by its name in the example code. If you want to use other components, you need to explicitly import them:

    import Placeholder from '../Placeholder'
    ;<Button>
      <Placeholder />
    </Button>

    Or you can explicitly import everything, to make examples easier to copy into your app code:

    import React from 'react'
    import Button from 'rsg-example/components/Button'
    import Placeholder from 'rsg-example/components/Placeholder'
    ;<Button>
      <Placeholder />
    </Button>

    require() statements are still supported.

    (#1116), #1075, #325 by @sapegin)

    Import statements in the editor

    You can also define aliases to make your imports more realistic:

    // ```jsx inside Markdown
    import React from 'react'
    import Button from 'rsg-example/components/Button'
    import Placeholder from 'rsg-example/components/Placeholder'

    In this example rsg-example is an alias defined with the moduleAliases config option.

    (#1142, #1076, #1109, #1074 by @sapegin)

    New editor and syntax highlighting

    We’ve replaced CodeMirror with react-simple-code-editor and now using Prism for code highlighting in static examples (instead of Highlight.js) and inside the editor. So code look the same everywhere in Styleguidist. We’ve also removed code splitting because react-simple-code-editor is so small and we can include it in the main bundle (8 KB vs 57 KB).

    There are some breaking changes in the config:

    • editorConfig and highlightTheme (already deprecated) options were removed.
    • No highlighting in fenced code blocks without specified language.
    • No highlighting in non-fenced code blocks.

    New editor

    (#1054 #987 by @sapegin)

    Drop React 15 support

    React 16.3 is the minimum supported version.

    Bug fixes

    • Add generated IDs to Markdown headings (#833, #1163 by @wkillerud)
    • Add pointer cursor on element
    • Add custom focus outline for element
    • Add focus outline for the editor
    • Better focus styles for inputs
    • Tweak colors to make them more accessible
    • Wrap long lines in pre tags
    • Incorrect current section highlighting on partial match (#1237, #1239 by @guyius)
    • Support webpack configs from react-scripts > 2.1.1 (#1241, #1243 by @oterral)
    • Change some dependencies to smaller alternatives (#1248 by @lukeed)

    Changes since 9.0.0-beta4

    Migrating from 8.x to 9.x

    1. Explicitly import all but the current component in your examples:
    // ```jsx inside ButtonGroup.md - 8.x
    // All style guide component are accessible globally
    ;<ButtonGroup>
      <Button>Eins</Button>
      <Button>Zwei</Button>
      <Button>Polizei</Button>
    </ButtonGroup>
    

    // ```jsx inside ButtonGroup.md - 8.x // Only the current (ButtonGroup) component is accessible import Button from './Button' ;<ButtonGroup> <Button>Eins</Button> <Button>Zwei</Button> <Button>Polizei</Button> </ButtonGroup>

    1. Replace highlightTheme or editorConfig.theme options with theme option:

    We don’t have predefined themes anymore, you can customize colors as you wish using the theme config option:

    // styleguide.config.js
    module.exports = {
      theme: {
        color: {
          codeComment: '#6d6d6d',
          codePunctuation: '#999',
          codeProperty: '#905',
          codeDeleted: '#905',
          codeString: '#690',
          codeInserted: '#690',
          codeOperator: '#9a6e3a',
          codeKeyword: '#1673b1',
          codeFunction: '#DD4A68',
          codeVariable: '#e90'
        }
      }
    }
    Commits

    The new version differs by 128 commits.

    • 8c2e2a1 9.0.0
    • d2511ca Chore: Run npm audit fix on examples
    • 38b4507 Chore: Remove Open Collective postinstall banner because it doesn't work anyway 🤔
    • 2f00a59 Chore: Update deps
    • 2f36348 Docs: Fix a few broken links to repo code in docs (#1272)
    • 7630f10 Docs: (Hopefully) fix Markdown 🤯
    • 75c393b Chore: Fix typos in comments (#1275)
    • c83d2c9 Fix: Upgrade react-group to v3 (#1270)
    • 0ecaaf5 Docs: Update react-native example (#1260)
    • 1c68615 Docs: Fix link (#1258)
    • 63a3a47 Fix: Change some dependencies to smaller alternatives (#1248)
    • 8554a3d Fix: Support webpack configs from react-scripts > 2.1.1 (#1241)
    • 4818ffe Docs: Fix webpack CSS loader example (#1245)
    • d52a42e Chore: update webpack-dev-server due to vulnerability (#1244)
    • 14ba635 Fix: Incorrect current section highlighting on partial match (#1239)

    There are 128 commits in total.

    See the full diff

    FAQ and help

    There is a collection of frequently asked questions. If those don’t help, you can always ask the humans behind Greenkeeper.


    Your Greenkeeper bot :palm_tree:

    greenkeeper 
    opened by greenkeeper[bot] 12
  • chore(deps): bump tmpl from 1.0.4 to 1.0.5

    chore(deps): bump tmpl from 1.0.4 to 1.0.5

    Bumps tmpl from 1.0.4 to 1.0.5.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps): bump tmpl from 1.0.4 to 1.0.5 in /example

    chore(deps): bump tmpl from 1.0.4 to 1.0.5 in /example

    Bumps tmpl from 1.0.4 to 1.0.5.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps): bump tar from 4.4.4 to 4.4.19 in /example

    chore(deps): bump tar from 4.4.4 to 4.4.19 in /example

    Bumps tar from 4.4.4 to 4.4.19.

    Commits
    • 9a6faa0 4.4.19
    • 70ef812 drop dirCache for symlink on all platforms
    • 3e35515 4.4.18
    • 52b09e3 fix: prevent path escape using drive-relative paths
    • bb93ba2 fix: reserve paths properly for unicode, windows
    • 2f1bca0 fix: prune dirCache properly for unicode, windows
    • 9bf70a8 4.4.17
    • 6aafff0 fix: skip extract if linkpath is stripped entirely
    • 5c5059a fix: reserve paths case-insensitively
    • fd6accb 4.4.16
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps): bump path-parse from 1.0.5 to 1.0.7

    chore(deps): bump path-parse from 1.0.5 to 1.0.7

    Bumps path-parse from 1.0.5 to 1.0.7.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps): bump path-parse from 1.0.5 to 1.0.7 in /example

    chore(deps): bump path-parse from 1.0.5 to 1.0.7 in /example

    Bumps path-parse from 1.0.5 to 1.0.7.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • is the repo still alive?

    is the repo still alive?

    opened by Kilerd 1
  • [Feature Request] Add support for iconPosition in Button

    [Feature Request] Add support for iconPosition in Button

    By default passing an icon prop to button places it to the left of the text. Sometimes you need the icon to the right side (eg: button with text Next ->)

    I can pick this up if the issue is accepted

    opened by rahulakrishna 0
  • chore(deps): bump merge-deep from 3.0.2 to 3.0.3 in /example

    chore(deps): bump merge-deep from 3.0.2 to 3.0.3 in /example

    Bumps merge-deep from 3.0.2 to 3.0.3.

    Commits
    • 628ff47 3.0.3
    • cfbe20c run verb to generate README documentation
    • e370968 Merge pull request #17 from jonschlinkert/key-properties
    • 393e2cb adding a test to ensure using merge-deep for inheritance still works
    • c39b161 add test to ensure constructor is not cloned
    • 11e5dd5 add isValidKey function to ensure only valid keys are merged
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • chore(deps): bump merge-deep from 3.0.2 to 3.0.3

    chore(deps): bump merge-deep from 3.0.2 to 3.0.3

    Bumps merge-deep from 3.0.2 to 3.0.3.

    Commits
    • 628ff47 3.0.3
    • cfbe20c run verb to generate README documentation
    • e370968 Merge pull request #17 from jonschlinkert/key-properties
    • 393e2cb adding a test to ensure using merge-deep for inheritance still works
    • c39b161 add test to ensure constructor is not cloned
    • 11e5dd5 add isValidKey function to ensure only valid keys are merged
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
Releases(v1.30.1)
react-var-ui is a simple React component library for variable setting and preview, inspired by iOS settings, react-dat-gui and dat.gui.

react-var-ui is a simple React component library for variable setting and preview, inspired by iOS settings, react-dat-gui and dat.gui. While some cod

Mat Sz 42 Sep 12, 2021
React components for Bulma framework

React-bulma-components React components for Bulma (v0.8.2) UI compatible with most used React Frameworks (Gatsby, CRA, Next.js) V4 Pool Please Check h

John 1.1k Sep 21, 2021
React utility component primitives & UI framework for use with Tailwind CSS

Tailwind React UI NB: As the 0.#.# version number suggests this is still very much work in progress, so semantic versioning will not be followed until

Ed Mortlock 237 Sep 11, 2021
The UI design language and React library for Conversational UI

The UI design language and React library for Conversational UI Website:https://chatui.io English | 简体中文 Features ?? Best Practices: The best practice

Alibaba 1.1k Sep 24, 2021
A React-based UI toolkit for the web

Blueprint Blueprint is a React-based UI toolkit for the web. It is optimized for building complex, data-dense web interfaces for desktop applications

Palantir Technologies 18.1k Sep 16, 2021
:atom_symbol: React primitive UI components built with styled-system.

Rebass React primitive UI components built with Styled System. https://rebassjs.org npm i rebass Getting Started import React from 'react' import { Bo

Rebass 7.5k Sep 15, 2021
Rheostat is a www, mobile, and accessible slider component built with React

Rheostat A mobile, tablet, desktop, and accessible slider for the web. Install npm install rheostat Initialize As of v3.0.0, the rheostat project reli

Airbnb 1.6k Aug 29, 2021
A frontend Framework for building B2B applications running in the browser on top of REST/GraphQL APIs, using ES6, React and Material Design

react-admin A frontend Framework for building data-driven applications running in the browser on top of REST/GraphQL APIs, using ES6, React and Materi

marmelab 17.8k Sep 20, 2021
📕React component library designed on the "new skeuomorphism" or "neumorphism" UI/UX trend.

?? React component library designed on the "new skeuomorphism" or "neumorphism" UI/UX trend.

Ankit Kumar Pandit 407 Sep 16, 2021
The official Semantic-UI-React integration

Semantic UI React Installation & Usage See the Documentation for an introduction, usage information, and examples. Built With Amazon Publishing — the

Semantic Org 12.4k Sep 16, 2021
React components for easier customization and smooth development flow.

Sha-el-design React components for easier customization and smooth development flow. ?? Features ?? Material inspired design. ?? A complete package of

null 28 Sep 7, 2021
:atom: Build virtual reality experiences with A-Frame and React.

aframe-react I recommend using vanilla A-Frame and aframe-state-component with static templating over aframe-react. React wastes a lot of cycles and i

Supermedium 1.2k Sep 23, 2021
🌈 A UI Design Language and React UI library

Ant Design An enterprise-class UI design language and React UI library. English | Português | 简体中文 ✨ Features ?? Enterprise-class UI designed for web

Ant Design Team 74.6k Sep 24, 2021
The Most Complete React UI Component Library

PrimeReact PrimeReact is a rich set of open source UI Components for React. See PrimeReact homepage for live showcase and documentation. Download Prim

PrimeFaces 2.2k Sep 24, 2021
Orbit-components is a React component library which provides developers with the easiest possible way of building Kiwi.com’s products.

Orbit-components is a React component library which provides developers with the easiest possible way of building Kiwi.com’s products.

Kiwi.com 1.1k Sep 23, 2021
React 17 & Bootstrap 5 & Material Design 2.0 UI KIT

React 17 & Bootstrap 5 & Material Design 2.0 UI KIT

MDBootstrap 1.2k Sep 22, 2021
dataminr-react-components - Collection of reusable React Components and utility functions.

react-components A collection of reusable React components with their own Flux lifecycle. What's inside react-components? Table Component From a simpl

Dataminr 261 Aug 5, 2021
👀 Easily apply tilt hover effect on React components - lightweight/zero dependencies

React Tilt ?? Easily apply tilt hover effect on React components Demo Demos created with React DemoTab ?? Install npm install react-parallax-tilt Feat

mkosir 367 Sep 16, 2021
Mantine is a MIT licensed open source react components and hooks library with focus on usability, accessibility and developer experience.

React components and hooks library with native dark theme support and focus on usability, accessibility and developer experience

Mantine 2k Sep 16, 2021