A collection of loading indicators animated with CSS for React

Related tags

react-spinkit
Overview

react-spinkit

A collection of loading indicators animated with CSS for React

Currently I've ported all the spinner animations from Spinkit. If you have other favorite css spinner you'd like to include, open an issue.

Install

$ npm install react-spinkit --save

Usage

var Spinner = require('react-spinkit');

<Spinner name='double-bounce' />

See more examples on the demo page.

CSS

CSS is loaded automatically when using Webpack with the css-loader and style-loader, or Browserify/CSSify to build your project.

External spinners

This also includes most of the spinners from loaders.css. Note that while all of the native spinners from Spinkit are contained within their bounding divs, some of the loaders.css spinners have a zero-sized parent div and extend outward from that (as you can see on the demos page). Regardless of this, they are all easily centerable with flexbox.

Webpack or Browserify is required

Currently we only support Browserify and Webpack. If you'd like support for other build tools that also support requiring CSS, PRs are welcome.

Fades in spinners after one second

According to research by Jakob Nielsen, feedback after user operations isn't necessary for about a second so by default, react-spinkit will fade in your spinner at one second. Nevertheless, you can configure spinner fade-in behavior with the fadeIn prop, which accepts values full (the default), half, quarter, and none for one second, a half second, a quarter second, and no fade in, respectively. For example: .

PropTypes

  • name—specify spinner to use (defaults to three-bounce).
  • fadeIn-set the time before the spinner fades in.
  • overrideSpinnerClassName—change the default sk-spinner className.
  • className-add a custom classname to the outer div.
  • color-programmatically set the color of the spinners; this can either be a hex value or a color word.

Server-side rendering

If you want to use this for server-side rendering, set process.env.REACT_SPINKIT_NO_STYLES in your server build environment, in webpack via webpack.DefinePlugin, or whatever is appropriate to your build process. This will skip the import of styles and allow evaluation of the SpinKit code in node.

Demo and documentation

http://kyleamathews.github.io/react-spinkit/

Issues
  • Error: Can't resolve 'react/lib/Object.assign' with React 15.0

    Error: Can't resolve 'react/lib/Object.assign' with React 15.0

    Using react-spinkit version 1.1.4 with React 15.0 results in the following error:

    ModuleNotFoundError: Module not found: Error: Can't resolve 'react/lib/Object.assign' in 'C:\projects\MyProject\node_modules\react-spinkit\dist'

    opened by nil4 15
  • Merge with 1.2.0 and requireCss prop support +modules.css support

    Merge with 1.2.0 and requireCss prop support +modules.css support

    Could you merge with 1.2.0, I need requireCss=false. How to use with modules.css?

    What about react theming support?

    opened by alex-shamshurin 13
  • Browserify complains about CSS

    Browserify complains about CSS

    I'm getting this from my Grunt Browserify output. Are these files really CSS or do they need some sort of preprocessing?

    >> /Users/me/project/node_modules/react-spinkit/css/fade-in.css:1
    >> @-webkit-keyframes fade-in {
    >> ^
    >> ParseError: Unexpected character '@'
    
    opened by 0x80 12
  • Invalid or unexpected token @-webkit-keyframes sk-fade-in

    Invalid or unexpected token @-webkit-keyframes sk-fade-in

    I have this error when trying to use:

    (function (exports, require, module, __filename, __dirname) { @-webkit-keyframes sk-fade-in {
                                                                  ^
    SyntaxError: Invalid or unexpected token
        at Object.exports.runInThisContext (vm.js:76:16)
        at Module._compile (module.js:542:28)
        at Module._extensions..js (module.js:579:10)
        at Object.require.extensions.(anonymous function) [as .js] (/media/hmtri/Soft  - Entertainment/Storage/Dropbox/Dropb
    ox/Study/Grade4/LTHD/PDFFiller/node_modules/babel-register/lib/node.js:152:7)
        at Module.load (module.js:487:32)
        at tryModuleLoad (module.js:446:12)
        at Function.Module._load (module.js:438:3)
        at Module.require (module.js:497:17)
        at require (internal/module.js:20:19)
        at Object.<anonymous> (/media/hmtri/Soft  - Entertainment/Storage/Dropbox/Dropbox/Study/Grade4/LTHD/PDFFiller/node_m
    odules/react-spinkit/dist/index.js:19:1)
        at Module._compile (module.js:570:32)
        at Module._extensions..js (module.js:579:10)
        at Object.require.extensions.(anonymous function) [as .js] (/media/hmtri/Soft  - Entertainment/Storage/Dropbox/Dropb
    ox/Study/Grade4/LTHD/PDFFiller/node_modules/babel-register/lib/node.js:152:7)
        at Module.load (module.js:487:32)
        at tryModuleLoad (module.js:446:12)
        at Function.Module._load (module.js:438:3)
    

    This is my webpack config:

    const webpack = require('webpack');
    const path = require('path');
    
    module.exports = {
        context: path.resolve(__dirname, 'src'),
    
        entry: {
            app: './app-client.js'
        },
    
        output: {
            path: path.join(__dirname, 'src', 'public', 'assets', 'js'),
            filename: 'bundle.js'
        },
        module: {
            rules: [
                {
                    test: path.join(__dirname, 'src'),
                    use: [
                        {
                            loader: 'babel-loader',
                            options: {
                                cacheDirectory: 'babel_cache',
                                presets: ['react', 'es2015', 'stage-0']
                            }
                        }
                    ],
                },
                {
                    test: /\.css$/,
                    use: [
                        {
                            loader : 'style-loader'
                        },
                        {
                            loader : 'css-loader',
                            options : {
                                modules : true
                            }
                        }
                    ]
                }
            ]
        },
    
        plugins: [
            new webpack.DefinePlugin({
                'process.env.NODE_ENV': JSON.stringify(process.env.NODE_ENV)
            }),
            new webpack.optimize.UglifyJsPlugin({
                compress: { warnings: true },
                mangle: true,
                sourceMap: true,
                beautify: false,
                dead_code: true
            })
        ]
    };
    

    I'm using "webpack": "^2.2.1", "css-loader": "^0.26.1", "style-loader": "^0.13.1"

    opened by hmtri1011 9
  • Add support for universal rendering

    Add support for universal rendering

    Because the server should not really rendered on server side (it's only temporary for the client normally) maybe just render "null" is quick solution.

    opened by aight8 8
  • Spinner not showing up unless importing css

    Spinner not showing up unless importing css

    Documentation states:

    CSS is loaded automatically when using Webpack with the css-loader and style-loader, or Browserify/CSSify to build your project.

    I had to import the css from react-spinkit to get it working

    import React from 'react';
    import Spinner from 'react-spinkit';
    //eslint-disable-next-line
    import '!style-loader!css-loader!react-spinkit/css/three-bounce.css';
    import style from './style.css';
    
    function LoadingSpinner() {
      return <Spinner className={style.loading} spinnerName="three-bounce" noFadeIn />;
    }
    
    export default LoadingSpinner;
    

    And in the style.css I had to center the loading spinner

    .loading {
      text-align: center;
    }
    

    How does one get webpack to automatically import the css ?

    Node: 7.7.3 Chrome "react": "15.5.4", "react-spinkit": "^2.1.1", "webpack": "^2.2.0",

    opened by kristinn93 6
  • Coloring the spinners

    Coloring the spinners

    Hello,

    I've seen that this has been proposed before and you said there that you would accept a pull request implementing this. I just wanted to make sure that you are still open to the idea before I actually implement this.

    Kind regards,

    Can

    opened by canibanoglu 5
  • Unexpected character '@'

    Unexpected character '@'

    Using webpack, imported spinkit and had this error

    ./~/react-spinkit/css/fade-in.css
    [0] Module parse failed: /Users/guest/workspace/demo-v1/react/node_modules/react-spinkit/css/fade-in.css `Unexpected character '@'` (1:0)
    [0] You may need an appropriate loader to handle this file type.
    [0] SyntaxError: Unexpected character '@' (1:0)
    [0]     at Parser.pp$4.raise (/Users/guest/workspace/demo-v1/react/node_modules/webpack/node_modules/acorn/dist/acorn.js:2221:15)
    [0]     at Parser.pp$7.getTokenFromCode (/Users/guest/workspace/demo-v1/react/node_modules/webpack/node_modules/acorn/dist/acorn.js:2756:10)
    [0]     at Parser.pp$7.readToken (/Users/guest/workspace/demo-v1/react/node_modules/webpack/node_modules/acorn/dist/acorn.js:2477:17)
    [0]     at Parser.pp$7.nextToken (/Users/guest/workspace/demo-v1/react/node_modules/webpack/node_modules/acorn/dist/acorn.js:2468:15)
    [0]     at Parser.parse (/Users/guest/workspace/demo-v1/react/node_modules/webpack/node_modules/acorn/dist/acorn.js:515:10)
    [0]     at Object.parse (/Users/guest/workspace/demo-v1/react/node_modules/webpack/node_modules/acorn/dist/acorn.js:3098:39)
    [0]     at Parser.parse (/Users/guest/workspace/demo-v1/react/node_modules/webpack/lib/Parser.js:902:15)
    [0]     at DependenciesBlock.<anonymous> (/Users/guest/workspace/demo-v1/react/node_modules/webpack/lib/NormalModule.js:104:16)
    [0]     at DependenciesBlock.onModuleBuild (/Users/guest/workspace/demo-v1/react/node_modules/webpack-core/lib/NormalModuleMixin.js:310:10)
    [0]     at nextLoader (/Users/guest/workspace/demo-v1/react/node_modules/webpack-core/lib/NormalModuleMixin.js:275:25)
    [0]  @ ./~/react-spinkit/dist/index.js 19:0-29
    

    I do have css-loader "^0.23.1" and style-loader "^0.13.1" . Any idea of what it could be?

    opened by rdavidwu 4
  • Timeout and color config, fix dimensions, pull in loaders.css, SSR, currentColor, spinnerName

    Timeout and color config, fix dimensions, pull in loaders.css, SSR, currentColor, spinnerName

    This PR addresses a few issues:

    • #33 : Since the fade in is set as a CSS animation, I couldn't do full configurability, but added 2 smaller intervals of fadeIn timing (half second and quarter second). This includes transitioning away from the noFadeIn prop with a deprecation warning.
    • #37 : This allows colorizing the spinners via props and inline styling for easier use. There were 2 spinners that weren't compatible with this approach because they relied on before/after pseudo-elements, and there are appropriate warnings for people who attempt to do that.
    • #48 : A few of the spinners had misconfigured dimensions on the containing div, resulting in difficulty centering them via flexbox, etc. Their dimensions have been adjusted accordingly.
    • #14 : Pulls in loaders.css for more spinners, with efforts to minimize package size growth. I omitted spinners from that repo that were very similar to pre-existing "native" spinners.
    • #20 / #51 : Made style imports dynamic based on environment variable, allowing server side rendering without lots of hacks. This is similar to react's dynamic behavior based on process.env.PRODUCTION and is a specific enough variable that it shouldn't collide.

    Additionally, updated tests, README, and demo site for all new features, and made changes to the test file to appease eslint (change to .jsx, convert tabs to spaces, etc) as well as organizational improvements (describe blocks to group related tests).

    All changes were tested inside of a working app for functionality and proper centering alignment.

    opened by merrywhether 4
  • use currentColor to inherit current font color

    use currentColor to inherit current font color

    Make all spinners inherit current set font color

    opened by hontas 4
  • Bump tmpl from 1.0.4 to 1.0.5 in /www

    Bump tmpl from 1.0.4 to 1.0.5 in /www

    Bumps tmpl from 1.0.4 to 1.0.5.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump tar from 2.2.1 to 2.2.2

    Bump tar from 2.2.1 to 2.2.2

    Bumps tar from 2.2.1 to 2.2.2.

    Commits
    • 523c5c7 2.2.2
    • 7ecef07 Bump fstream to fix hardlink overwriting vulnerability
    • 9fc84b9 Use {} for hardlink tracking instead of []
    • 15e59f1 Only track previously seen hardlinks
    • 4f85851 Ignore potentially unsafe files
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump tar from 2.2.1 to 2.2.2 in /www

    Bump tar from 2.2.1 to 2.2.2 in /www

    Bumps tar from 2.2.1 to 2.2.2.

    Commits
    • 523c5c7 2.2.2
    • 7ecef07 Bump fstream to fix hardlink overwriting vulnerability
    • 9fc84b9 Use {} for hardlink tracking instead of []
    • 15e59f1 Only track previously seen hardlinks
    • 4f85851 Ignore potentially unsafe files
    • See full diff in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump merge from 1.2.0 to 1.2.1 in /www

    Bump merge from 1.2.0 to 1.2.1 in /www

    Bumps merge from 1.2.0 to 1.2.1.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump hosted-git-info from 2.2.0 to 2.8.9 in /www

    Bump hosted-git-info from 2.2.0 to 2.8.9 in /www

    Bumps hosted-git-info from 2.2.0 to 2.8.9.

    Changelog

    Sourced from hosted-git-info's changelog.

    2.8.9 (2021-04-07)

    Bug Fixes

    2.8.8 (2020-02-29)

    Bug Fixes

    • #61 & #65 addressing issues w/ url.URL implmentation which regressed node 6 support (5038b18), closes #66

    2.8.7 (2020-02-26)

    Bug Fixes

    • Do not attempt to use url.URL when unavailable (2d0bb66), closes #61 #62
    • Do not pass scp-style URLs to the WhatWG url.URL (f2cdfcf), closes #60

    2.8.6 (2020-02-25)

    2.8.5 (2019-10-07)

    Bug Fixes

    • updated pathmatch for gitlab (e8325b5), closes #51
    • updated pathmatch for gitlab (ffe056f)

    2.8.4 (2019-08-12)

    ... (truncated)

    Commits
    • 8d4b369 chore(release): 2.8.9
    • 29adfe5 fix: backport regex fix from #76
    • afeaefd chore(release): 2.8.8
    • 5038b18 fix: #61 & #65 addressing issues w/ url.URL implmentation which regressed nod...
    • 7440afa chore(release): 2.8.7
    • 2d0bb66 fix: Do not attempt to use url.URL when unavailable
    • f2cdfcf fix: Do not pass scp-style URLs to the WhatWG url.URL
    • e1b83df chore(release): 2.8.6
    • ff259a6 Ensure passwords in hosted Git URLs are correctly escaped
    • 624fd6f chore(release): 2.8.5
    • Additional commits viewable in compare view
    Maintainer changes

    This version was pushed to npm by nlf, a new releaser for hosted-git-info since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump ua-parser-js from 0.7.12 to 0.7.28

    Bump ua-parser-js from 0.7.12 to 0.7.28

    Bumps ua-parser-js from 0.7.12 to 0.7.28.

    Commits
    • 1d3c98a Revert breaking fix #279 and release as 0.7.28
    • 535f11b Delete redundant code
    • 642c039 Fix #492 LG TV WebOS detection
    • 3edacdd Merge branch 'master' into develop
    • acc0b91 Update contributor list
    • f726dcd Merge branch 'master' into develop
    • 383ca58 More test for tablet devices
    • 7c8aa43 Minor rearrangement
    • 09aa910 Add new device & browser: Tesla
    • 557cc21 More test for latest phones with unique form factor (fold/flip/qwerty/swivel)
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump ua-parser-js from 0.7.12 to 0.7.28 in /www

    Bump ua-parser-js from 0.7.12 to 0.7.28 in /www

    Bumps ua-parser-js from 0.7.12 to 0.7.28.

    Commits
    • 1d3c98a Revert breaking fix #279 and release as 0.7.28
    • 535f11b Delete redundant code
    • 642c039 Fix #492 LG TV WebOS detection
    • 3edacdd Merge branch 'master' into develop
    • acc0b91 Update contributor list
    • f726dcd Merge branch 'master' into develop
    • 383ca58 More test for tablet devices
    • 7c8aa43 Minor rearrangement
    • 09aa910 Add new device & browser: Tesla
    • 557cc21 More test for latest phones with unique form factor (fold/flip/qwerty/swivel)
    • Additional commits viewable in compare view

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump lodash from 4.17.4 to 4.17.21

    Bump lodash from 4.17.4 to 4.17.21

    Bumps lodash from 4.17.4 to 4.17.21.

    Commits
    • f299b52 Bump to v4.17.21
    • c4847eb Improve performance of toNumber, trim and trimEnd on large input strings
    • 3469357 Prevent command injection through _.template's variable option
    • ded9bc6 Bump to v4.17.20.
    • 63150ef Documentation fixes.
    • 00f0f62 test.js: Remove trailing comma.
    • 846e434 Temporarily use a custom fork of lodash-cli.
    • 5d046f3 Re-enable Travis tests on 4.17 branch.
    • aa816b3 Remove /npm-package.
    • d7fbc52 Bump to v4.17.19
    • Additional commits viewable in compare view
    Maintainer changes

    This version was pushed to npm by bnjmnt4n, a new releaser for lodash since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump y18n from 3.2.1 to 3.2.2 in /www

    Bump y18n from 3.2.1 to 3.2.2 in /www

    Bumps y18n from 3.2.1 to 3.2.2.

    Commits
    Maintainer changes

    This version was pushed to npm by oss-bot, a new releaser for y18n since your current version.


    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
  • Bump elliptic from 6.3.3 to 6.5.4 in /www

    Bump elliptic from 6.3.3 to 6.5.4 in /www

    Bumps elliptic from 6.3.3 to 6.5.4.

    Commits

    Dependabot compatibility score

    Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


    Dependabot commands and options

    You can trigger Dependabot actions by commenting on this PR:

    • @dependabot rebase will rebase this PR
    • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
    • @dependabot merge will merge this PR after your CI passes on it
    • @dependabot squash and merge will squash and merge this PR after your CI passes on it
    • @dependabot cancel merge will cancel a previously requested merge and block automerging
    • @dependabot reopen will reopen this PR if it is closed
    • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
    • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
    • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
    • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
    • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
    • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
    • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

    You can disable automated security fix PRs for this repo from the Security Alerts page.

    dependencies 
    opened by dependabot[bot] 0
Releases(v2.0.0)
  • v2.0.0(Jan 31, 2017)

    https://github.com/KyleAMathews/react-spinkit/pull/49

    This is a breaking change as people might have been targeting the older class names.

    Source code(tar.gz)
    Source code(zip)
A collection of loading indicators animated with CSS for React

react-spinkit A collection of loading indicators animated with CSS for React Currently I've ported all the spinner animations from Spinkit. If you hav

Kyle Mathews 1.4k Oct 2, 2021
Make beautiful, animated loading skeletons that automatically adapt to your app.

react-loading-skeleton Make beautiful, animated loading skeletons that automatically adapt to your app. Basic usage Install by npm/yarn with react-loa

David Tang 2.4k Oct 13, 2021
Amazing collection of React spinners components with pure css

React Spinners CSS Loaders (Vue, Angular) Amazing collection of React spinners components with pure css. The React spinners are based on loading.io an

Josh Kuttler 274 Sep 24, 2021
3D animated react button component with progress bar.

3D animated react button component with progress bar.

MD. Ariful Alam 68 Oct 5, 2021
⚪ SVG-Powered component to easily create skeleton loadings.

SVG-Powered component to easily create placeholder loadings (like Facebook's cards loading). Features ⚙️ Customizable: Feel free to change the colors,

Danilo Woznica 11.6k Oct 13, 2021
:cyclone: Simple react.js component for an inline progress indicator

react-progress-button Simple React component for a circular Progress Button. Demo Install npm install react-progress-button --save Example Controlled

Mathieu Dutour 517 Sep 11, 2021
react-loader - React component that displays a spinner via spin.js until your component is loaded.

react-loader react-loader provides your React.js component a simple mechanism for rendering a loading spinner (via spin.js) while data is loading, suc

Cognizant Studio 529 Sep 16, 2021
Easy way to block the user from interacting with your UI.

react-block-ui Easy way to block the user from interacting with your UI. About This library contains easy to use components to prevent the user from i

Availity 271 Sep 13, 2021
Progress component for React and React Native

react-progress-label Progress component for React and React Native Installation yarn add react-progress-label npm install react-progress-label --save

SWIFT CARROT Technologies 95 May 16, 2021
Creates a download handler function and gives progress information

Creates a download handler function and gives progress information

Olavo Parno 57 Sep 15, 2021
❄️ The ultimate Line Progress Bar UI for React - Supports 🌸 Natural color gradients & ☃️ Coherent border rounding

Frogress ❄️ The ultimate Line Progress Bar UI for React @frogress/line ?? Installation # Install peer depedencies yarn add react react-dom styled-comp

Junho Yeo 12 Sep 6, 2021